$re = '/[-!$%^&*()_+|~=`{}\[\]:\x22;\x27<>?,.\/]+/m';
$str = '{partA}".\'"\'."{partB}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);