re = /[-!$%^&*()_+|~=`{}\[\]:\x22;\x27<>?,.\/]+/m
str = '{partA}".\'"\'."{partB}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end