using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"I do \"".*?\""(?:, \"".*?\"")*";
string input = @"I do ""x"", ""y "", "" z""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}