package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`I do \".*?\"(?:, \".*?\")*`)
var str = `I do "x", "y ", " z"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}