$re = '/^\d{1,2}(\-| ){1}\w+(\-| ){1}\d{4}$/m';
$str = '21-05112-2001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);