import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\t([\\-0-9a-z.]+)\\n.*?$\\n([\\d,]+).*?$\\n.*?$";
final String string = "104699 pojazdy.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "55,00 zł\n"
+ "67,65 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104700 tuning.org.pl\n"
+ "Artykuły sponsorowane\n"
+ "55,00 zł\n"
+ "67,65 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104701 mscar.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "55,00 zł\n"
+ "67,65 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104702 gokartf1.pl\n"
+ "Artykuły sponsorowane\n"
+ "55,00 zł\n"
+ "67,65 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104703 fmcars.pl\n"
+ "Artykuły sponsorowane\n"
+ "65,00 zł\n"
+ "79,95 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104704 www.autostarter.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "65,00 zł\n"
+ "79,95 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104705 ilespala.pl\n"
+ "Artykuły sponsorowane\n"
+ "65,00 zł\n"
+ "79,95 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104706 diagnostic.net.pl\n"
+ "Artykuły sponsorowane\n"
+ "55,00 zł\n"
+ "67,65 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104707 www.corrida.info.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104708 auto-land.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104709 mpbartoszewski.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104710 kierowcy-badania.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104711 www.platnedrogi.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104712 www.bal-jendro.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104713 mazda-dealer-gliwice.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104714 www.instrukcje-haynes.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104715 www.paliwa-marvis.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104716 www.skupaut-opolskie.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104717 wobimoto.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104718 letsgo-rent.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104719 s-camp.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104720 optifin.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104721 7gr.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104722 majercars.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104723 www.mtbkrapkowice.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104724 cube-skupaut.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104725 www.elzem.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104726 ab-geko.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104727 pl-skupaut.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104728 autoserwislodz.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104729 mazda-dyga.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104730 autoq.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104731 www.clonmel.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104732 jartrans.net.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104733 moto-firmy.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104734 wroclaw-skupsamochodow.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104735 astat-motors.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104736 autonyga.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104737 www.moto-art2.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104738 skup-aut-bytom.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104739 automotofrance.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104740 www.19688.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104741 www.wymianaoponkrakow.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104742 kraftmedia.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104743 autosport-lodz.pl\n"
+ "Artykuły sponsorowane\n"
+ "69,00 zł\n"
+ "84,87 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104744 www.autooscar.com.pl\n"
+ "Artykuły sponsorowane\n"
+ "60,00 zł\n"
+ "73,80 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104745 easymotionvan.pl\n"
+ "Artykuły sponsorowane\n"
+ "60,00 zł\n"
+ "73,80 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104746 www.bezpieczniejnadrogach.pl\n"
+ "Artykuły sponsorowane\n"
+ "85,00 zł\n"
+ "104,55 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104747 zmotoryzowana.pl\n"
+ "Artykuły sponsorowane\n"
+ "90,00 zł\n"
+ "110,70 zł brutto Oczekuje na dodanie wytycznych Części ASO \n"
+ "104748 www.motowydawnictwo.pl\n"
+ "Artykuły sponsorowane\n"
+ "202,50 zł\n"
+ "249,08 zł brutto Oczekuje na dodanie wytycznych Części ASO \n";
final String subst = "\"$1\",\"2020-02-28\",\"$2\",\"Linkhouse\",\"Daniel Galecki\",\"Moto\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}