#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|[^%])(?:%%)*(%(?:\d+\$)?(?:\+)?(?:0|'.)?(?:\-)?(?:\d+)?(?:\.\d+)?[bcdeEufFgGosxX])"
Local $sString = "<?php" & @CRLF & _
"$n = 43951789;" & @CRLF & _
"$u = -43951789;" & @CRLF & _
"$c = 65; // ASCII コードの 65 は 'A' です" & @CRLF & _
"" & @CRLF & _
"// %% に注目しましょう。これは、リテラル '%' を文字として出力します" & @CRLF & _
"printf("%%b = '%b'\n", $n); // 2 進表現" & @CRLF & _
"printf("%%c = '%c'\n", $c); // ascii 文字を表示します。chr() 関数と同じです" & @CRLF & _
"printf("%%d = '%d'\n", $n); // 標準の整数表現" & @CRLF & _
"printf("%%e = '%e'\n", $n); // 科学記法" & @CRLF & _
"printf("%%u = '%u'\n", $n); // 正の整数の、符号なし整数表現" & @CRLF & _
"printf("%%u = '%u'\n", $u); // 負の整数の、符号なし整数表現" & @CRLF & _
"printf("%%f = '%f'\n", $n); // 浮動小数点表現" & @CRLF & _
"printf("%%o = '%o'\n", $n); // 8 進表現" & @CRLF & _
"printf("%%s = '%s'\n", $n); // 文字列表現" & @CRLF & _
"printf("%%x = '%x'\n", $n); // 16 進表現 (小文字)" & @CRLF & _
"printf("%%X = '%X'\n", $n); // 16 進表現 (大文字)" & @CRLF & _
"" & @CRLF & _
"printf("%%+d = '%+d'\n", $n); // 正の整数に符号指定子を使用" & @CRLF & _
"printf("%%+d = '%+d'\n", $u); // 負の整数に符号指定子を使用" & @CRLF & _
"?>" & @CRLF & _
"" & @CRLF & _
"<?php" & @CRLF & _
"$s = 'monkey';" & @CRLF & _
"$t = 'many monkeys';" & @CRLF & _
"" & @CRLF & _
"printf("[%s]\n", $s); // 標準の文字列出力" & @CRLF & _
"printf("[%10s]\n", $s); // 空白を使用して右詰め" & @CRLF & _
"printf("[%-10s]\n", $s); // 空白を使用して左詰め" & @CRLF & _
"printf("[%010s]\n", $s); // ゼロ埋めは文字列でも可能です" & @CRLF & _
"printf("[%'#10s]\n", $s); // ゼロの代わりに独自の文字 '#' で埋めます" & @CRLF & _
"printf("[%10.10s]\n", $t); // 左詰めを行い、10 文字以上は切り捨てます" & @CRLF & _
"?>" & @CRLF & _
"例9 sprintf(): 整数のゼロ埋め" & @CRLF & _
"" & @CRLF & _
"<?php" & @CRLF & _
"$isodate = sprintf("%04d-%02d-%02d", $year, $month, $day);" & @CRLF & _
"?>" & @CRLF & _
"例10 sprintf(): 通貨をフォーマットする例" & @CRLF & _
"" & @CRLF & _
"<?php" & @CRLF & _
"$money1 = 68.75;" & @CRLF & _
"$money2 = 54.35;" & @CRLF & _
"$money = $money1 + $money2;" & @CRLF & _
"// echo $money は "123.1" を出力します。" & @CRLF & _
"$formatted = sprintf("%01.2f", $money);" & @CRLF & _
"// echo $formatted は "123.10"を出力します" & @CRLF & _
"?>" & @CRLF & _
"例11 sprintf(): 科学記法" & @CRLF & _
"" & @CRLF & _
"<?php" & @CRLF & _
"$number = 362525200;" & @CRLF & _
"" & @CRLF & _
"echo sprintf("%.3e", $number); // 3.625e+8 を出力します" & @CRLF & _
"?>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")