# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|[^%])(?:%%)*(%(?:\d+\$)?(?:\+)?(?:0|'.)?(?:\-)?(?:\d+)?(?:\.\d+)?[bcdeEufFgGosxX])"
test_str = ("<?php\n"
"$n = 43951789;\n"
"$u = -43951789;\n"
"$c = 65; // ASCII コードの 65 は 'A' です\n\n"
"// %% に注目しましょう。これは、リテラル '%' を文字として出力します\n"
"printf(\"%%b = '%b'\\n\", $n); // 2 進表現\n"
"printf(\"%%c = '%c'\\n\", $c); // ascii 文字を表示します。chr() 関数と同じです\n"
"printf(\"%%d = '%d'\\n\", $n); // 標準の整数表現\n"
"printf(\"%%e = '%e'\\n\", $n); // 科学記法\n"
"printf(\"%%u = '%u'\\n\", $n); // 正の整数の、符号なし整数表現\n"
"printf(\"%%u = '%u'\\n\", $u); // 負の整数の、符号なし整数表現\n"
"printf(\"%%f = '%f'\\n\", $n); // 浮動小数点表現\n"
"printf(\"%%o = '%o'\\n\", $n); // 8 進表現\n"
"printf(\"%%s = '%s'\\n\", $n); // 文字列表現\n"
"printf(\"%%x = '%x'\\n\", $n); // 16 進表現 (小文字)\n"
"printf(\"%%X = '%X'\\n\", $n); // 16 進表現 (大文字)\n\n"
"printf(\"%%+d = '%+d'\\n\", $n); // 正の整数に符号指定子を使用\n"
"printf(\"%%+d = '%+d'\\n\", $u); // 負の整数に符号指定子を使用\n"
"?>\n\n"
"<?php\n"
"$s = 'monkey';\n"
"$t = 'many monkeys';\n\n"
"printf(\"[%s]\\n\", $s); // 標準の文字列出力\n"
"printf(\"[%10s]\\n\", $s); // 空白を使用して右詰め\n"
"printf(\"[%-10s]\\n\", $s); // 空白を使用して左詰め\n"
"printf(\"[%010s]\\n\", $s); // ゼロ埋めは文字列でも可能です\n"
"printf(\"[%'#10s]\\n\", $s); // ゼロの代わりに独自の文字 '#' で埋めます\n"
"printf(\"[%10.10s]\\n\", $t); // 左詰めを行い、10 文字以上は切り捨てます\n"
"?>\n"
"例9 sprintf(): 整数のゼロ埋め\n\n"
"<?php\n"
"$isodate = sprintf(\"%04d-%02d-%02d\", $year, $month, $day);\n"
"?>\n"
"例10 sprintf(): 通貨をフォーマットする例\n\n"
"<?php\n"
"$money1 = 68.75;\n"
"$money2 = 54.35;\n"
"$money = $money1 + $money2;\n"
"// echo $money は \"123.1\" を出力します。\n"
"$formatted = sprintf(\"%01.2f\", $money);\n"
"// echo $formatted は \"123.10\"を出力します\n"
"?>\n"
"例11 sprintf(): 科学記法\n\n"
"<?php\n"
"$number = 362525200;\n\n"
"echo sprintf(\"%.3e\", $number); // 3.625e+8 を出力します\n"
"?>\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.