$re = '/^(?!([^%\n]*%){2}).+/m';
$str = 'characters % that can match any single
group items % together into%
regex is cool';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);