re = /^(?!([^%\n]*%){2}).+/m
str = 'characters % that can match any single
group items % together into%
regex is cool'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end