package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|\"(?<cap>[^\"]*)\"|(?<cap>-+))`)
var str = `upuu unuu uutu yuyy "uu ii oo pp" iii ooo ppp
usuu uunu utuu yyoy - iii ooo ppp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}