$re = '/(?|\"(?<cap>[^\"]*)\"|(?<cap>-+))/m';
$str = 'upuu unuu uutu yuyy "uu ii oo pp" iii ooo ppp
usuu uunu utuu yyoy - iii ooo ppp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);