const regex = /^(?=^.*[a-z]#[a-z].*$|^.*\b[a-z0-9][a-z]#[a-z][a-z0-9]\b.*$)(?!.*[0-9]#[0-9]|.*[a-z]#[0-9]|.*[0-9]#[a-z]|.*[\s,^]#[\s,^]).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=^.*[a-z]#[a-z].*$|^.*\\b[a-z0-9][a-z]#[a-z][a-z0-9]\\b.*$)(?!.*[0-9]#[0-9]|.*[a-z]#[0-9]|.*[0-9]#[a-z]|.*[\\s,^]#[\\s,^]).*$', 'gm')
const str = `ex_date( ds23d#d4ff5 )
ex_date( asa#ss32as, #, s3ds#sdsd)
ex_date12(asa#ss32as,#,s3ds#sdsd)
( asa#ss32as, a#b, s3ds#sdsd)
date( asa#ss32as, #, s3ds#sdsd, a#b)
ex_date( asa#ss32as, a#b, s3ds#sdsd, 4#5)
ewe#ewe
we#ere, er2e#er3e, #
p_price(we#ee)
p_date( we#rer , )
p_car ( df#e ,)
re#ee , erer#r,
#wewqwq
ddf\$%^#gfg^h`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}