using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CHANGE.+(?=SHOES(?!.*NIKE))";
string input = @"
CHANGE OF SHOES TO NIKE AIRS.
CHANGE THE SHOES TO REBOOK.
CHANGE PANTS AND SHOES TO ADIDAS WOMENS
CHANGE.+(?=SHOES).+(?!NIKE).+";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}