import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CHANGE.+(?=SHOES(?!.*NIKE))";
final String string = "\n"
+ "CHANGE OF SHOES TO NIKE AIRS.\n\n"
+ "CHANGE THE SHOES TO REBOOK.\n\n"
+ "CHANGE PANTS AND SHOES TO ADIDAS WOMENS\n\n"
+ "CHANGE.+(?=SHOES).+(?!NIKE).+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}