#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^.*\.(.*\.[a-z]{0,3})|(?i)([a-z]{0,3}\..*\.[a-z]{0,3}|.*\.[a-z]{0,3})$$"
Local $sString = "ch.iqos.com" & @CRLF & _
"discoveriqos.com" & @CRLF & _
"faramentol.ro" & @CRLF & _
"foodhouse.md" & @CRLF & _
"futurosinhumo.com" & @CRLF & _
"ganaconpmi.com" & @CRLF & _
"getinfo.kr" & @CRLF & _
"heatnotburn.se" & @CRLF & _
"iqommunity.ro" & @CRLF & _
"iqosclub.cz" & @CRLF & _
"iqosclub.sk" & @CRLF & _
"iqosclubcanarias.com" & @CRLF & _
"iqosempfehlen.at" & @CRLF & _
"iqositalia.it" & @CRLF & _
"iqosphere.jp" & @CRLF & _
"iqossvc.kr" & @CRLF & _
"iqosveda.cz" & @CRLF & _
"iqosveda.sk" & @CRLF & _
"newcreations.kr" & @CRLF & _
"prohibicionmentolado2020.es" & @CRLF & _
"proibicao-mentol2020.pt" & @CRLF & _
"qreator.ro" & @CRLF & _
"referiqosmy.com" & @CRLF & _
"shareiqos.ch" & @CRLF & _
"timeforchanges.ch" & @CRLF & _
"tryiqos.kr" & @CRLF & _
"unsmoke.de" & @CRLF & _
"iqostravel.com" & @CRLF & _
"iqostage.jp" & @CRLF & _
"iqos-register.jp" & @CRLF & _
"mystartapp.org" & @CRLF & _
"iqosclub.ch" & @CRLF & _
"dimensions.kz" & @CRLF & _
"www.tryiqos.ru" & @CRLF & _
"www.timeforchanges.ch" & @CRLF & _
"www.testiqos.ch" & @CRLF & _
"readmodel.m.sogou.com" & @CRLF & _
"www.shareiqos.ch"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")