import re
regex = re.compile(r"(?i)^.*\.(.*\.[a-z]{0,3})|(?i)([a-z]{0,3}\..*\.[a-z]{0,3}|.*\.[a-z]{0,3})$$", flags=re.MULTILINE)
test_str = ("ch.iqos.com\n"
"discoveriqos.com\n"
"faramentol.ro\n"
"foodhouse.md\n"
"futurosinhumo.com\n"
"ganaconpmi.com\n"
"getinfo.kr\n"
"heatnotburn.se\n"
"iqommunity.ro\n"
"iqosclub.cz\n"
"iqosclub.sk\n"
"iqosclubcanarias.com\n"
"iqosempfehlen.at\n"
"iqositalia.it\n"
"iqosphere.jp\n"
"iqossvc.kr\n"
"iqosveda.cz\n"
"iqosveda.sk\n"
"newcreations.kr\n"
"prohibicionmentolado2020.es\n"
"proibicao-mentol2020.pt\n"
"qreator.ro\n"
"referiqosmy.com\n"
"shareiqos.ch\n"
"timeforchanges.ch\n"
"tryiqos.kr\n"
"unsmoke.de\n"
"iqostravel.com\n"
"iqostage.jp\n"
"iqos-register.jp\n"
"mystartapp.org\n"
"iqosclub.ch\n"
"dimensions.kz\n"
"www.tryiqos.ru\n"
"www.timeforchanges.ch\n"
"www.testiqos.ch\n"
"readmodel.m.sogou.com\n"
"www.shareiqos.ch")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")