package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>.* - (.*) - ([A-Z]{2})<`)
var str = `<div class="endereco-item">
<h2 class="azulclaro identify">Casa</h2>
<div class="entrelinha_0"></div>
<div class="font_15"></div>
<div class="font_15"></div>
<div class="font_15">R: Antonio Pires dos Santos, 647 praça central</div>
<div class="font_15">Parque santo antonio - Sao Paulo - SP</div>
<div class="font_15">CEP: 55555-555</div>
<div class="font_15">Fone: (11)943-056-295 (55)555-555-555</div>
<div id="ctl00_Body_rptEnderecos_ctl00_dvRadio" class="font_15 custom-checkbox">
<input type="radio" id="radio0" name="radioSelect" checked onclick="setPrincipal(0)" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}