# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r">.* - (.*) - ([A-Z]{2})<"
test_str = ("<div class=\"endereco-item\">\n"
" <h2 class=\"azulclaro identify\">Casa</h2>\n"
" <div class=\"entrelinha_0\"></div>\n"
" <div class=\"font_15\"></div>\n"
" <div class=\"font_15\"></div>\n"
" <div class=\"font_15\">R: Antonio Pires dos Santos, 647 praça central</div>\n"
" <div class=\"font_15\">Parque santo antonio - Sao Paulo - SP</div>\n"
" <div class=\"font_15\">CEP: 55555-555</div>\n"
" <div class=\"font_15\">Fone: (11)943-056-295 (55)555-555-555</div>\n"
" <div id=\"ctl00_Body_rptEnderecos_ctl00_dvRadio\" class=\"font_15 custom-checkbox\">\n"
" <input type=\"radio\" id=\"radio0\" name=\"radioSelect\" checked onclick=\"setPrincipal(0)\" />")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.