using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\s*(\s*\d{4}\s*-\s*\d{2}\s*-\s*\d{2}\s*)\s*\]|(?<=\[|-)\s*(.*?)\s*(?=-|\])|([A-Za-z].*)";
string input = @"[category - subcategory] [some text - more text ] [2018-12-31] text title here
[category - subcategory] [some text] [ 2018 - 12 -31 ] text title here more text
[category] [some text - more text - even more] [2018-12-31] text title here more text
[category] [some text - more text - even more - some text - more text - even more ] [2018-12-31] text title here more text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}