import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\s*(\\s*\\d{4}\\s*-\\s*\\d{2}\\s*-\\s*\\d{2}\\s*)\\s*\\]|(?<=\\[|-)\\s*(.*?)\\s*(?=-|\\])|([A-Za-z].*)";
final String string = "[category - subcategory] [some text - more text ] [2018-12-31] text title here\n"
+ "[category - subcategory] [some text] [ 2018 - 12 -31 ] text title here more text\n"
+ "[category] [some text - more text - even more] [2018-12-31] text title here more text\n"
+ "[category] [some text - more text - even more - some text - more text - even more ] [2018-12-31] text title here more text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}