import re
regex = re.compile(r"^([a-zA-Z]+) ?([1-9]+)[, ]*[0-9]{,2}:[0-9]{,2}[^,]+, ?T=([-0-9]+)degr?", flags=re.MULTILINE)
test_str = ("# Measurements started\n"
"Sep 9, 9:05, T=22deg\n"
"SEP 9, 10:15, T=25deg\n"
"# Taking a coffee break\n"
"Sep 9, 11:15, T=-10deg\n"
"# Weekend\n"
"Sept 12, 09:00AM, T=32deg\n"
"Oct12 13:00, T=32degr")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")