#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!cpc|accounts\.)(google|bing|search\.yahoo|search\.myway|yandex|duckduckgo|ecosia|search\.tb\.ask|baidu)(?!.*cpc)"
Local $sString = "google/cpc/[google][cpc][house][sale]" & @CRLF & _
"google/cpc/[google][cpc][condo][sale]" & @CRLF & _
"accounts.google.com.sg" & @CRLF & _
"accounts.google.co.id" & @CRLF & _
"google.com" & @CRLF & _
"google.com.ph" & @CRLF & _
"google.co.th" & @CRLF & _
"bing.com" & @CRLF & _
"google.co.uk" & @CRLF & _
"com.google.android.googlequicksearchbox" & @CRLF & _
"google.com.sg" & @CRLF & _
"google.com.au" & @CRLF & _
"google.com.vn" & @CRLF & _
"google.ca" & @CRLF & _
"google.co.id" & @CRLF & _
"google.com.hk" & @CRLF & _
"search.yahoo.com" & @CRLF & _
"duckduckgo.com" & @CRLF & _
"google.de" & @CRLF & _
"ph.search.yahoo.com" & @CRLF & _
"google.co.in" & @CRLF & _
"google.fr" & @CRLF & _
"google.co.jp" & @CRLF & _
"google.co.kr" & @CRLF & _
"google.com.my" & @CRLF & _
"google.ae" & @CRLF & _
"google.se" & @CRLF & _
"google.ch" & @CRLF & _
"int.search.myway.com" & @CRLF & _
"yandex.ru" & @CRLF & _
"google.ru" & @CRLF & _
"google.com.tw" & @CRLF & _
"google.nl" & @CRLF & _
"cn.bing.com" & @CRLF & _
"ecosia.org" & @CRLF & _
"google.it" & @CRLF & _
"google.dk" & @CRLF & _
"google.co.nz" & @CRLF & _
"int.search.tb.ask.com" & @CRLF & _
"search.yahoo.co.jp" & @CRLF & _
"google.co.za" & @CRLF & _
"google.no" & @CRLF & _
"google.es" & @CRLF & _
"google.be" & @CRLF & _
"th.search.yahoo.com" & @CRLF & _
"google.fi" & @CRLF & _
"baidu.com" & @CRLF & _
"google.ie" & @CRLF & _
"google.com.tr" & @CRLF & _
"uk.search.yahoo.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")