re = /(?<=>)\s+(?=<)/
str = '<div>
<p>Some paragraph here</p>
<div data="some data > < here">
<p>some subparagraph here</p>
</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end