use strict;
my $str = '3,3,"","","",f,f';
my $regex = qr/(?<![^,])""(?![^,])/mp;
my $subst = '" "';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";