$re = '/(?<![^,])""(?![^,])/m';
$str = '3,3,"","","",f,f';
$subst = "\" \"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;