$re = '/:((?!=).+):/';
$str = 'SELECT name, @age:=(age+5), address, @total:=(total+1)
FROM `users`
WHERE
id = :id:
name = :LOWER(name):
date = :strftime(\'%Y-%m %H:%i:%s\', updated_at):
hash = :MD5(concat(status, salt)):
desc = :hash=foo:
ORDER BY name ASC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);