import Foundation
let pattern = #":((?!=).+):"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SELECT name, @age:=(age+5), address, @total:=(total+1)
FROM `users`
WHERE
id = :id:
name = :LOWER(name):
date = :strftime('%Y-%m %H:%i:%s', updated_at):
hash = :MD5(concat(status, salt)):
desc = :hash=foo:
ORDER BY name ASC
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)