$re = '/:(?!=).+:/';
$str = 'SELECT name, @age:=(age+5), address, @total:=(total+1)
FROM `users`
WHERE
id = :id:
name = :LOWER(name):
date = :strftime(\'%Y-%m %H:%i:%s\', updated_at):
hash = :MD5(concat(status, salt)):
desc = :hash=foo:
ORDER BY name ASC
SELECT mytable.id, DATE_FORMAT(mytable.created_at,\'%d/%m/%Y %H:%i:%s\') AS created_at_uk FROM mytable WHERE mytable.id = ?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);