$re = '/.*(UNIQUE|\"(?:response|someothedata|otherdata|somedata)\")/m';
$str = '{ "name": "abc", "response": { "postback": "UNIQUE-a651-95e4834b63cc" } }
{ "name": "abc", "response": { "postback": "a651-95e4834b63cc" } }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);