package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/dp\/([^\/]*)\/`)
var str = `http://www.amazon.in/Sinew-Nutrition-Decaffeinated-Unroasted-Management/dp/B01LF7Y0S4/ref=sr_1_1?ie=UTF8&qid=1484716249&sr=8-1&keywords=green+coffee+beans`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}