re = /\/dp\/([^\/]*)\//
str = 'http://www.amazon.in/Sinew-Nutrition-Decaffeinated-Unroasted-Management/dp/B01LF7Y0S4/ref=sr_1_1?ie=UTF8&qid=1484716249&sr=8-1&keywords=green+coffee+beans'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end