const regex = /^X\.(?:[3-9]|1[0-3])(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^X\\.(?:[3-9]|1[0-3])(?!\\d)', 'gm')
const str = `X.2
X.3word
X.4w
X.5w
X.6w
X.7w
X.8w
X.9w
X.10w
X.11w
X.12w
X.13w
X.14`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}