re = /^X\.(?:[3-9]|1[0-3])(?!\d)/m
str = 'X.2
X.3word
X.4w
X.5w
X.6w
X.7w
X.8w
X.9w
X.10w
X.11w
X.12w
X.13w
X.14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end