$re = '/^(?:([^:\n]+):)?([^(\n]+)(.+)?/m';
$str = 'Misc Parts
Retail:Oil-20W50 Phillips (Aviation Oil, 20W50 12/1 QT (sold by the case))
Discount 10% AA (10% Discount)
Shipping & Handling (Shipping & Handling)
Tailwheel Parts:A4050 (Cone Bearing)
Tailwheel Parts:A4138 (Bearing Race)
Shipping & Handling (Shipping & Handling)
Tailwheel Parts:ABI-3234-00 (Thrust Plate Assy.)
Shipping & Handling (Shipping & Handling)
Shipping & Handling (Shipping & Handling)
Shipping & Handling (Shipping & Handling)
Tailwheel Parts-Assemblies:ABI-3235-02 (Upper Dust Cover Straight Arm )
Tailwheel Parts:ABI-3206-00 (Thrust Washer)
Tailwheel Parts:ABI-3233-00 (Compression Spring)
Tailwheel Parts:ABI-3205-00 (Bushing)
Tailwheel Parts:ABI-3219-02 (Pawl (Long))
Shipping & Handling (Shipping & Handling)
Shipping & Handling (Shipping & Handling)
This should match as part number
Vendor:Part Number
Vendor:Part Number (Description)
Hello (World:Meow)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);