import Foundation
let pattern = #"^(?:([^:\n]+):)?([^(\n]+)(.+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Misc Parts
Retail:Oil-20W50 Phillips (Aviation Oil, 20W50 12/1 QT (sold by the case))
Discount 10% AA (10% Discount)
Shipping & Handling (Shipping & Handling)
Tailwheel Parts:A4050 (Cone Bearing)
Tailwheel Parts:A4138 (Bearing Race)
Shipping & Handling (Shipping & Handling)
Tailwheel Parts:ABI-3234-00 (Thrust Plate Assy.)
Shipping & Handling (Shipping & Handling)
Shipping & Handling (Shipping & Handling)
Shipping & Handling (Shipping & Handling)
Tailwheel Parts-Assemblies:ABI-3235-02 (Upper Dust Cover Straight Arm )
Tailwheel Parts:ABI-3206-00 (Thrust Washer)
Tailwheel Parts:ABI-3233-00 (Compression Spring)
Tailwheel Parts:ABI-3205-00 (Bushing)
Tailwheel Parts:ABI-3219-02 (Pawl (Long))
Shipping & Handling (Shipping & Handling)
Shipping & Handling (Shipping & Handling)
This should match as part number
Vendor:Part Number
Vendor:Part Number (Description)
Hello (World:Meow)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)