# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=\b\d+[xX]\b)/\n/gm;t' <<< "Some description art.nr: 4457 72 1x ACOUCH 90X200 NICE GRAY (3 colli) 1x matras 85x205x12 2x matras 80x190x11 Some specs 14x Premium otherproduct 90x200x23 HR34"