$re = '`^(.*? -name\b).*?(-descr\b.*)?$`m';
$str = 'runcmd -name abcd xyz -descr abc def
runcmd -name abcd xyz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);