re = /^(.*? -name\b).*?(-descr\b.*)?$/m
str = 'runcmd -name abcd xyz -descr abc def
runcmd -name abcd xyz
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end