import re
regex = re.compile(r"((\d){21}(,)?){1,4}((\d){21})+")
test_str = ("111111111111111111111\n"
"111111111111111111111,\n"
"111111111111111111111,111111111111111111111\n"
"111111111111111111111,111111111111111111111,111111111111111111111x\n"
"111111111111111111111,111111111111111111111000\n"
"111111111111111111111,,111111111111111111111\n"
"111111111111111111111,111111111111111111111,111111111111111111111,\n"
"111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111\n"
"111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")