import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+ Muffin)";
final String string = "Raspberry Muffin\n"
+ "Raspberry \n"
+ "Raisin Muffin\n"
+ "Muffin\n"
+ "Wings\n"
+ "Soup\n"
+ "Toast\n"
+ "Tater Tots\n"
+ "Tatted Tots\n"
+ "Tatter Tots\n"
+ "Shake\n"
+ "Salami\n"
+ "Salmon\n"
+ "Hash Browns\n"
+ "Quinoa\n"
+ "Raspberry Muffin\n"
+ "Bud Light\n"
+ "Coke Zero\n"
+ "Diet Coke\n"
+ "French Onion Soup\n"
+ "Tacos\n"
+ "Turkey\n"
+ "What time is it\n"
+ "Cranberries\n"
+ "Yogurt\n"
+ "YT\n"
+ "Peas\n"
+ "Chocolate\n"
+ "Pancakes\n"
+ "Lime\n"
+ "Hot Dog\n"
+ "French Fried\n"
+ "Egg\n"
+ "Sashimi\n"
+ "Cherrios\n"
+ "Buzzy\n"
+ "Carrot \n"
+ "Coke\n"
+ "Granola\n"
+ "Hi \n"
+ "Gum\n"
+ "test\n"
+ "Hamburger\n"
+ "Lol\n"
+ "Meat\n"
+ "foot\n"
+ "Omelet\n"
+ "Pretzels\n"
+ "Siracha hot sauce\n"
+ "Strawberry smoothie\n"
+ "What now?\n"
+ "Cheerios\n"
+ "pretzel\n"
+ "Doctor Pepper\n"
+ "Root Beer\n"
+ "diet root beer\n"
+ "Orange\n"
+ "Canola\n"
+ "Plum\n"
+ "Spaghetti\n"
+ "Sushi\n"
+ "Agave\n"
+ "Agave syrup\n"
+ "Alcohol\n"
+ "Almond\n"
+ "Almonds\n"
+ "Apple\n"
+ "Apples\n"
+ "Apples\n"
+ "Artichoke\n"
+ "Asparagus\n"
+ "Are these okay?\n"
+ "Are these ok?\n"
+ "Avocado\n"
+ "Avocado oil\n"
+ "badlist\n"
+ "Bacon\n"
+ "Bananas\n"
+ "Beans\n"
+ "Beans / Legumes\n"
+ "Beef\n"
+ "Beet sugar\n"
+ "Beets\n"
+ "Blackberries\n"
+ "Blueberries\n"
+ "Brazil nuts\n"
+ "bread\n"
+ "Broccoli\n"
+ "Brussels sprouts\n"
+ "Butter\n"
+ "Cabbage\n"
+ "Candied nuts\n"
+ "Can\n"
+ "candy\n"
+ "Canola oil\n"
+ "Carrots\n"
+ "Cashew\n"
+ "Cashews\n"
+ "Cashews\n"
+ "Cauliflower\n"
+ "Celery\n"
+ "Celery root\n"
+ "cereal\n"
+ "Cheese\n"
+ "Cheetos\n"
+ "Cherries\n"
+ "Chia and Flax seeds\n"
+ "Chicken\n"
+ "Chickpeas\n"
+ "coconut sugar\n"
+ "Coffee\n"
+ "Corn\n"
+ "Corn oil\n"
+ "Crab\n"
+ "Cream\n"
+ "Cream cheese\n"
+ "Cucumber\n"
+ "Diet coke\n"
+ "diet soda\n"
+ "Eggplant\n"
+ "Eggs\n"
+ "Fish\n"
+ "French fries\n"
+ "Fried chicken\n"
+ "Frozen yogurt\n"
+ "Fruit\n"
+ "Ghee\n"
+ "Gin\n"
+ "grains\n"
+ "Green onions\n"
+ "Green peas\n"
+ "Greens (spinach, kale, etc.)\n"
+ "Guacamole\n"
+ "Herbs (parsley, basil, etc.)\n"
+ "Honeyed nuts\n"
+ "Ice cream\n"
+ "Jerky\n"
+ "kale\n"
+ "ketchup\n"
+ "Lamb\n"
+ "Lard\n"
+ "Lettuce\n"
+ "Lima beans\n"
+ "Lobster\n"
+ "Macadamias\n"
+ "Mango\n"
+ "Mayo\n"
+ "Mayonnaise\n"
+ "Meatballs\n"
+ "Meatloaf\n"
+ "meatloaf\n"
+ "Melon\n"
+ "Milk\n"
+ "Milky Way\n"
+ "Mushrooms\n"
+ "Mussels\n"
+ "Nuts\n"
+ "Olive oil\n"
+ "Olives\n"
+ "Onions\n"
+ "Oranges\n"
+ "Oysters\n"
+ "Palm sugar\n"
+ "Parsnips\n"
+ "pasta\n"
+ "Peach\n"
+ "Pears\n"
+ "Pecans\n"
+ "Peppers\n"
+ "pizza\n"
+ "Plantains\n"
+ "Plums\n"
+ "Popcorn\n"
+ "Popsicle\n"
+ "Pork\n"
+ "potato\n"
+ "Potatoes\n"
+ "poultry\n"
+ "Pumpkin\n"
+ "Raspberries\n"
+ "Rice\n"
+ "Rum\n"
+ "Shrimp\n"
+ "Snack mix\n"
+ "Soda\n"
+ "Soybean oil\n"
+ "Steak\n"
+ "Stevia\n"
+ "Strawberries\n"
+ "Sugar\n"
+ "Sugar-free soda\n"
+ "Sugared nuts\n"
+ "Sunflower seeds\n"
+ "Sweet potatoes and yams\n"
+ "Tallow\n"
+ "Tea\n"
+ "Tomatoes\n"
+ "tomatoes\n"
+ "Trail mix\n"
+ "Vegetable oil\n"
+ "Vodka\n"
+ "Walnuts\n"
+ "Water\n"
+ "What can I say\n"
+ "Whiskey\n"
+ "whole grain bread\n"
+ "Whole Milk\n"
+ "why\n"
+ "wine\n"
+ "Winter squash\n"
+ "Xylitol\n"
+ "Yogurt-covered nuts\n"
+ "Zucchini\n"
+ "zzz";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}