import Foundation
let pattern = #"(.+ Muffin)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Raspberry Muffin
Raspberry
Raisin Muffin
Muffin
Wings
Soup
Toast
Tater Tots
Tatted Tots
Tatter Tots
Shake
Salami
Salmon
Hash Browns
Quinoa
Raspberry Muffin
Bud Light
Coke Zero
Diet Coke
French Onion Soup
Tacos
Turkey
What time is it
Cranberries
Yogurt
YT
Peas
Chocolate
Pancakes
Lime
Hot Dog
French Fried
Egg
Sashimi
Cherrios
Buzzy
Carrot
Coke
Granola
Hi
Gum
test
Hamburger
Lol
Meat
foot
Omelet
Pretzels
Siracha hot sauce
Strawberry smoothie
What now?
Cheerios
pretzel
Doctor Pepper
Root Beer
diet root beer
Orange
Canola
Plum
Spaghetti
Sushi
Agave
Agave syrup
Alcohol
Almond
Almonds
Apple
Apples
Apples
Artichoke
Asparagus
Are these okay?
Are these ok?
Avocado
Avocado oil
badlist
Bacon
Bananas
Beans
Beans / Legumes
Beef
Beet sugar
Beets
Blackberries
Blueberries
Brazil nuts
bread
Broccoli
Brussels sprouts
Butter
Cabbage
Candied nuts
Can
candy
Canola oil
Carrots
Cashew
Cashews
Cashews
Cauliflower
Celery
Celery root
cereal
Cheese
Cheetos
Cherries
Chia and Flax seeds
Chicken
Chickpeas
coconut sugar
Coffee
Corn
Corn oil
Crab
Cream
Cream cheese
Cucumber
Diet coke
diet soda
Eggplant
Eggs
Fish
French fries
Fried chicken
Frozen yogurt
Fruit
Ghee
Gin
grains
Green onions
Green peas
Greens (spinach, kale, etc.)
Guacamole
Herbs (parsley, basil, etc.)
Honeyed nuts
Ice cream
Jerky
kale
ketchup
Lamb
Lard
Lettuce
Lima beans
Lobster
Macadamias
Mango
Mayo
Mayonnaise
Meatballs
Meatloaf
meatloaf
Melon
Milk
Milky Way
Mushrooms
Mussels
Nuts
Olive oil
Olives
Onions
Oranges
Oysters
Palm sugar
Parsnips
pasta
Peach
Pears
Pecans
Peppers
pizza
Plantains
Plums
Popcorn
Popsicle
Pork
potato
Potatoes
poultry
Pumpkin
Raspberries
Rice
Rum
Shrimp
Snack mix
Soda
Soybean oil
Steak
Stevia
Strawberries
Sugar
Sugar-free soda
Sugared nuts
Sunflower seeds
Sweet potatoes and yams
Tallow
Tea
Tomatoes
tomatoes
Trail mix
Vegetable oil
Vodka
Walnuts
Water
What can I say
Whiskey
whole grain bread
Whole Milk
why
wine
Winter squash
Xylitol
Yogurt-covered nuts
Zucchini
zzz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)