package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+\.{1}\S+\.{1}\S+`)
var str = `a.b.c
a..b.c
abc.d.e.14.f `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}