$re = '/\S+\.{1}\S+\.{1}\S+/';
$str = 'a.b.c
a..b.c
abc.d.e.14.f ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);