using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\w| )+)(?=(?:[^`]*`[^`]*`)*[^`]*$)";
string input = @"one `two three` four five `six` seven
one` two three `four five` six `seven";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}