$re = '/(\{(?>[^{}]+|(?1))*\})/m';
$str = 'This is working: {test1|test2|test3}, this is working {test1|{test2|test3}}, this is not working: {test1|{test2|test3}|test4}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);