re = /(\{(?>[^{}]+|(?1))*\})/m
str = 'This is working: {test1|test2|test3}, this is working {test1|{test2|test3}}, this is not working: {test1|{test2|test3}|test4}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end