using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|""(?=[^""]+""))[^""()]*(?:""(*SKIP)(*FAIL)|\K[()])";
string input = @"""hi (text here) and (other text)"" come (again) and ""(again)"", right?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}