re = /(?:\G(?!^)|"(?=[^"]+"))[^"()]*(?:"(*SKIP)(*FAIL)|\K[()])/
str = '"hi (text here) and (other text)" come (again) and "(again)", right?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end