#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^CTR.*$"
Local $sString = "CTRasdkljfhalksjdfhalksjdfhalskjhf" & @CRLF & _
"2f3232rjfkalkj23f2a523gap289gaCTR" & @CRLF & _
"23rCTRCTRs;flkjs;ldfjkCTR" & @CRLF & _
"CTR23dfhalskjhf" & @CRLF & _
"CTRasdkljfhalksjd234251dfhalskjhf" & @CRLF & _
"CTRasdkljf3623462346jdfhalskjhf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")